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Demystifying Curves

Curves got you running scared?? Well, get
over your fear of curves with this step-by-
step tutorial that will introduce you to vector
drawing and path editing.

Many graphic artists, including professionals, cringe at the mere mention of curves and paths. Why are curves
so intimidating?

Paths and curves, or Bézier curves as they are sometimes called, are the basis of graphic design and vector
drawings. You see them used everyday in logos, illustrations, and Web sites. In this tutorial, we will give you the
basics so you can draw, bend, and push with the best of them.

Creating a New Document
We will start this tutorial by opening a
new document (File > New). Choose
Illustration as the file type and press OK.



Preparing the Document
Next, we will prepare the document to measure in pixels. To do
this, choose Layout > Rulers. When the Rulers dialog box
opens, pick Ruler 5 from the drop-down menu (see example)
and press OK. Ruler 5 is preset to measure in pixels.

Any unit of measurement will work; however, for this tutorial
we will be using pixels.

Now we want to set our grids to snap to pixels. This will pre-
vent objects from falling between pixels. To set your grids,
choose Layout > Grids. In the Grids dialog box, change the
Line Distance X and Y to 1 pixel. Then, check Snap to X and
Span to Y. Finally, click OK to save your choices and close the
dialog box.

Demystifying Curves (continued)

Getting Acquainted with Canvas‘ Path Tools
Now that your document is setup, we are ready to get started.
The first thing you need to do is locate the Path tools in the
Toolbox. It is a good idea to drag them away from the Toolbox
so they are easily accessible.



Using the Curve tool
We start by first selecting a black stroke and “no fill
ink” from the Inks palette. This will make it easier for
you to draw.

To change the stroke and fill inks, you must first
make sure no objects are selected. This is easily
done by pressing the Esc key several times. With
nothing selected, open the Pen Inks palette and
change the ink color to black. Now open the Fill Inks
palette and choose “no ink”, represented by the
white box with a slash through it. Your inks should
look like the example on the right.

Next select the Curve tool from the Toolbox or Path
tools palette.

Before we move on, let‘s take a minute to learn the names and basic
functions of the different Path tools.

Curve Tool: Used to draw precise paths with
straight or curved segments.

Freehand Tool: Used to draw paths by sim-
ply dragging the cursor.

Polygon Tool: Used to create paths with
straight line segments.

Auto Curve Tool: Used to draw curved
paths.

Reshape Tool: Used to modify existing
paths.

Push Tool: Allows you to edit curves.

Path tools palette

Defining Curves
Now, let‘s take a look at the components of a curve.

Anchor Points: Determine where a path starts, goes,
and ends. They appear as small blue squares that
turn to empty blue square outlines when selected.

Tangent Lines: Control the shape of curved segments.
Also note that Tangent Lines affect the adjacent seg-
ment.

Handles: Used to control Tangent Lines.
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We start by clicking the Path tool in our work area. When you click
and release the Path tool, it will create an anchor point that is free
of handles or a tangent line. Since this anchor will eventually be
one of the sharp ends we do not want handles on this particular
anchor point.

Note: your anchor will appear as a blue square outline.

Click Path tool and release

Now, click the second anchor point to the right and below the first
but this time do not release the mouse button (see example).

Click second anchor but don‘t release mouse button

Before releasing the mouse button, drag it up and away to create a
curved path. You‘ll see the tangent line and handles appear as you
drag.

When the curve is to your liking, release the mouse button.

In this exercise, our goal is to create a swooshing object like the one below. The trick is to create smooth
curves and sharp ends.

Click Path tool and release

Click second anchor but
don‘t release mouse button

Drag handle up and away

Using the same technique, create a
third anchor point and drag the cursor
down and away to produce another
curve.

Click and drag the third anchor point
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Using Modifier Keys While Drawing
In Canvas, you may use modifier keys while drawing to constrain or edit a path segment. The following is a list
of modifier keys and their functions.

Shift: Pressing the Shift key as you set an anchor will place the anchor point at a 45 degree intervals relative
to the previous one.

Shift + Drag: Pressing the Shift key while dragging out a handle will constrain your tangent line to 45 degree
angles.

Option (Mac) or Ctrl (windows): Pressing these keys as you set an anchor creates a straight line segment.

Delete: Pressing the Delete key removes the last segment you created.

Create a fourth anchor point;
however, this time, just click
and release the mouse button
to create an anchor point with-
out handles.

Click and release the fourth anchor point

Now, we‘re going to complete
the bottom portion of the
swoosh by repeating the same
steps we used to create the
top.

Click the mouse button to cre-
ate a fifth anchor point and
drag the handle out.

Click and drag the fifth anchor point

Click and drag the sixth anchor
point.

Click and drag

Click on the starting anchor point

Complete the path by clicking
on the starting anchor.

Demystifying Curves (continued)



In this next step we are going to learn to use the Freehand tool.

The Freehand tool allows you to draw paths or objects by simply dragging the cursor, just like you would with a
pencil.

Freehand Tool
First select the Freehand tool from the Toolbox or
Path tools palette.

Next, double-click on the Freehand tool to bring up
the Freehand Tolerance dialog box. Using this dialog
box, you could tell Canvas to use more or less
anchor points to represent a curve. The scale is set
from 1-5, where 5 tells Canvas to use the lesser
amount of anchor points. Press OK when you have
made a selection.

Note: This setting will greatly influence the
operation of the Freehand tool.

Now, with the Freehand tool selected, press the
mouse button and draw a path the same manner you
would if you were using a pencil. Release the mouse
button when you have reached the end of your path.

For this example, we have drawn the shape of a
man‘s face.

Canvas will smooth out the curves when you release
the mouse button.

Next, we will use the Polygon tool to create a triangle with straight line segments. The Polygon tool works
similar to the Curve tool but only creates straight line segments.
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Polygon Tool
First select the Polygon tool from the Toolbox or
Path tools palette.

Now, click in the work area to create the first anchor
point.

Click a second anchor point. Notice that dragging
the anchor points using the Polygon tool will not
produce tangent line or handles.

Create a third anchor point

Finish the path by clicking on the starting anchor
point to create an offset triangle.

The finished triangle should look like the example on
the right.

Note: The modifier keys mentioned at the
end of Step 2 will also work with the Poly-
gon tool.

Click to create anchor point

Create a second anchor point

Completed polygon
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We will go over the Auto Curve tool next. The ease of use and practicality of the Auto Curve tool make it one of
the most useful drawing tools in Canvas. Using this tool, you could create curves without positioning tangent
lines or dragging handles. You simply just click to set the anchor point and a smooth curve segment appears
automatically.

Tip: You may smooth a polygon by first selecting the
polygon object and then choosing Object > Path >
Smooth. Using this function will change the straight
line segments to curve segments. The function is
also reve rsible by choosing Object > Path >
Unsmooth.

Polygon with smooth function applied

Auto Curve tool
First select the Auto Curve tool from the Toolbox or
Path tools palette.

Click your first anchor point somewhere in the work
area.

Click a second anchor point above the first. Notice
the curve has not started to form because it requires
at least three anchors.

Click a third anchor point a little higher and slightly
to the right of the second, you will see the curved
path start to develop.

Continue to click a curve to get a feel for the tool.

Click anchor point
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Complete the path by clicking on the starting anchor.

Note: It is not required for you close a path to
use any of the drawing tools. Paths may be left
open by pressing Esc twice at any point in the
drawing.

On the right the completed curve is used as the body of
a baby chicken illustration.

Next, we will review the functions of the Reshape tool. The Reshape tool provides an easy-to-use, interactive
way to edit paths.

Reshape tool
In this section, we are going to use the Reshape tool to
restructure one side of the oval.

To start, use the Selection tool to select the oval we are
going to reshape.
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Then, select the Reshape tool from the Toolbox or Path
tools palette.

Move the pointer toward the path and a reshape symbol
(~) will appear. The symbol indicates that you are
ready to drag the reshape path.

Click on the path and drag a new segment in the shape
you want. For our example, we want to cut off the end
of the oval.

Release the mouse button and Canvas will apply the
new segment you created.

After you use the Reshape tool, the object remains
selected or in edit mode so that you may continue to
use the Reshape tool to further modify the path.
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The Push tool provides an alternative way of editing paths. The tools lets you form curves based on a mea-
surement range without having to edit anchor points or tangent lines.

Push Tool
In this exercise, we will use the Push tool to shape the
circular path on the right into an apple.

To get started, you must first select the circle using the
Selection tool

Next, double-click on the Push tool.

The Push Tool Dialog box opens. In this box, enter the
range and press OK. Entering a small range will create
more points and push a smaller area, whereas entering
a larger range will lower the number of points used and
push a larger area.

For our example, we entered 100 pixels as the range.
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Now, with the Push tool, push down on the top of the cir-
cle.

Using the same setting, push up on the bottom of the cir-
cle.

Double-click on the Push tool again to open the Push tool
dialog box. Increase the Range to 150 pixels or whichever
measurement you want to use and press OK.

Now, push in one side of the circle just below the halfway
point.
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Repeat the process on the other side to com-
plete the apple shape.

Here is the completed apple with a shine as
well as a stem and leaf.

Sometimes a project may require you to edit an existing path or objects. In the following example, we will edit
an existing path by adding an anchor point and modifying the tangent lines.

Editing Paths
On the right, you‘ll see the object we are going to modify.
It is a basic rectangle with four straight segments with no
handles or tangent lines.

To edit the object (or path) first double-click on it to enter
edit mode.
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For this first step, we are simply going to select an
anchor point using the Selection tool and stretch it out
to a new location to alter the path.

There are two ways to edit the anchor point‘s
position:

1. Click on the anchor point using the Selection tool
and drag it to the new location.

2. With the anchor point selected, use the arrow keys
to move it to its new location

Note: These techniques also works with
curved segments.

Next, we are going to further modify the same anchor by
adding handles to it and using the handles to create a
curve.

So with the anchor point still selected, right-click
(Windows) or Control-click (Mac) to open the Path-editing
context menu.

Select Add Handle from the menu.
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You will now see the handles appear as small blue dots
on either side of the selected anchor point.

Place your cursor on the top handle and drag the tan-
gent line downward to produce a smooth curve.

It is a good idea to experiment with this function to see
how the tangent line affects the curve. Notice that the
transition (bend) of curve could be changed by dragging
the tangent line left and right.

Now we are going to add a new anchor point to the
object.

With the object still in edit mode, right-click (Windows)
or Control-click (Mac) to open the Path-editing context
menu.
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Select Add Point from this menu.

The context menu will disappear and the new point
will be visible with its handles.

Next, grab one of the handles and swing it around.
Also, try moving the anchor point to create interest-
ing bends and curves.

You might have noticed when adding anchor points or handles, that the Path-editing context menu has several
features not examined in the course of this exercise. The following is the complete list of features and func-
tions found in the Path-editing context menu.

Undo: Will undo the last operation.

Delete Point: Deletes selected point. Note, you must right-click (Windows) or Control-click (Mac) on an
anchor point for this function to be active. If multiple points are selected the function will appear as Delete
Selected Points.
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Cusp: On anchor points, this option deletes the point‘s tangent lines.
On tangent line handles, the option makes the path either smooth or
curved at the anchor point. To be smooth, the anchor point must have
both sides of a tangent line. When smooth, the tangent lines are
always 180 degrees from each other. When the anchor is a corner,
the tangent line segments can move independently around the anchor
point. If multiple points are selected, the function will appear as Cusp
Selected Points.

Smooth: Will create a smooth curve when a straight segment anchor
point is selected. If multiple points are selected, the function will
appear as Smooth Selected Points.

Fillet: Creates a radius corner between or more points. When using
Fillet, a dialog box will appear asking for a radius value. Entering a
large radius value will produce a larger curved segment. If multiple
points are selected, the function will appear as Fillet Selected Points.

Add Point: Inserts an anchor point with a tangent line at the point
where you clicked on the path.

Break: Splits a path segment and adds anchor points to the ends of the resulting segments.

Join: Connects the selected points with a straight segment.

Delete Handle: Removes handles and the effects of a tangent line on the path.

Add Handle: Adds one or two tangent line segments to the anchor point.

Straighten: Makes a path segment straight by removing tangent lines from the segment’s anchor points.

Enable Symmetrical Drag: Allows you to easily create a symmetrical design from a circle, rectangle, or a
complex group of objects.

Important: To edit the paths of EasyShapes, spirals, multigons, etc., you must first convert them to
paths. This is done by first selecting them than choosing Object > Path > Convert to Path. Also,
grouped objects such as clipart must be ungrouped (Object > Ungroup) before their paths can be
modified.

We conclude this tutorial by leaving you with an extreme example of curves. Below is an example of tribal art,
which is commonly used as the basis for tattoos. While this style of art usually consists of only one or two col-
ors but they are rich in curves. Below the example is the same artwork in edit mode, which reveals the anchor
points the author used to create it.

If you wish, you may download this file and experiment with the handles, anchor points, and options learned
in this tutorial. You could come modify it to come up with a completely new design or just examine how it was
made.

Download Tribal Art File Size: 32 KB
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