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Creating Animated Logos

 

Creating Animated Logos

Bring objects to life in this easy to follow tutorial. Learn how-to create 

stunning rotating logos using Canvas' Extrude tool, your creativity, 

and a little bit of math. 

Have you ever wanted to create your own spinning logo for your Web site or presentation? If the answer is yes, 

just pour yourself a cup of coffee, sharpen your pencil, and sit back because we are going show you how... 

Canvas style. 

In the following exercise we are going to take an existing vector logo and make it come to life. 

Preparing the document

We start the tutorial by opening Canvas and 

selecting Animation as the document type. 

Next, choose Layout > Document Setup 

from the menu bar. 

In the Document Setup palette you will first 

select your paper color, which will be the 

background color of your animation. We 

chose white. 

Next select the Units of measurement, 

choose Pixels.

Finally select Custom from the Document 

Size option and make the width and height 

of your document 160 pixels. 

When you have adjusted all of your settings, 

click OK. 



Now get the logo you want to use and place (File > Place) it into your Canvas 

Animation file. It must be a vector illustration.

If you don't have a vector logo to work with, click on the link below to use ours. 

 CV8 Logo (canvas file size - 963 KB)

 
 

are set to "0". 

X 0, Y 0, Z 0

This setting will position the logo facing 

straight ahead.

 

 

 

 

 

precisely rotate your logo in the following 

steps but for now make sure all your settings 

Extruding the Logo

Now place the logo into the center of the 

working area and open the Extrude palette 

(Effects > Extrude). 

From this palette you want to choose Parallel 

as the extrude type. 

You could experiment with Light Color and 

Light Intensity. 

For Light Source, it's very important that you 

follow along very closely. For the initial logo 

extrusion, set the Light Source as follows

X 25, Y 20, Z 100

This setting will place the light source in front 

of the image and just a little to the left. It is 

important to maintain a constant light source 

location as the logo rotates to give it a 

realistic appearance. 

For the Ambient Light Setting, move the 

slider just a little past the halfway point. 

Next we have the Rotation angles, which are 

very important. You'll use these settings to 

 

 
Creating Animated Logos (Continued)

 

http://www.deneba.com/community/howto/animated_logo/cv8_logo.cnv
http://www.deneba.com/community/howto/animated_logo/cv8_logo.cnv


Creating the Frames

Now we'll create the frames to illustrate the movement. Each 

frame will represent a progression of motion as the logo turns. 

We chose to use 20 frames for our tutorial. Keep in mind the 

more frames you use the smoother your rotation will appear; 

however, this added smoothness comes with a price: file size. 

The more frames you use, the smoother the animation looks but 

the larger your file size will be. 

To add frames to your animation open the Document Layout 

palette (Layout > Document Layout) and click on the New Frame 

icon represented by a white page with the corner folded down. 

As you click on the icon you will see the frames appear. Continue 

to click on the icon until you have a total of 20 frames. 

 

Copying to Layers

Now, we need to copy the extruded logo to the frames we just 

created with perfect placement. The easiest way to do that is to 

choose Object > Arrange > Copy to Layers with the logo on 

Frame 1 selected. You will be presented with a palette listing all 

the available frames. Click on Frame 2, then continue to select 

the subsequential frames all the way to Frame 12 while holding 

down the Ctrl key in Windows or the Command key in Mac. The 

selected frames will become highlighted as you select them. 

When you are done your palette should look like the example on 

the right. Remember we only want to copy the logo to Frames 2 

through 12. When you are done selecting the frames press 

Select. 

Note: Make sure you don't copy the object to the same frame 

you are copying it from; i.e., Frame 1. 

Tip: It is best to plan out the rotation before hand. In this 

exercise, we have done the guess work for you. Using a different 

number of frames will require you to change the rotation angles 

and frame speed.
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Making the Rotation

Now is time to make our logo spin. This is where you have to dust off the old calculator and do a little math. 

Since we are going to use 20 frames to complete one rotation or 360°, then we need to divide 360 by 20, 

which equals 18. So we need to rotate our logo 18° every frame to get a smooth precise rotation. 

Now that we have the math out of the way, let's get to work. We 

are going to start with Frame 1. To select or return to Frame 1 go 

to the Slide/Frame buttons at the bottom of the layout area and 

click on Frame 1. 

You should have a frame with a forward facing logo. To make the logo start rotating you must first select it, 

then open the Extrude palette (Effects > Extrude) and change the Y Rotation Angle from 0 to 90 and press 

Apply. Your logo will rotate 90° and appear to be on its side. 

Now, select Frame 2 using the Slide/Frame buttons at the bottom 

of the layout area and repeat the same steps but this time change 

the Y Rotation Angle to 72 and press Apply. 

Next, using these same steps continue to go through each frame and change the Y Rotation Angle for each of 

the extruded logos through Frame 11. 

Below are examples of the logo and the settings for each progressive frame. 

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 90, Z = 0

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 72, Z = 0

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 54, Z = 0

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 36, Z = 0
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Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 18 , Z = 0

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 0, Z = 0



Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -18 , Z = 0

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -36, Z = 0

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -54 , Z = 0

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -72, Z = 0

Light Source:

X = 25, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -90 , Z = 0
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Animating the Back of the Logo

Now we are going to flip the logo around and continue 

to rotate it. So, select the logo in Frame 12 and go to 

Effects > Flip > Horizontal. See example. 



 

 

 

When you flipped the logo the Extrude Light Source 

will remain true to the original position. Since we are 

now looking at the back side of the logo the lighting 

source will appear to be on the wrong side. To make 

this illusion work we have to force it back to its 

original location. To do this, simply change the X 

Light Source setting from 25 to 75. 

Now, even though the Light Source appears to be on 

the wrong side it will work correctly. Just keep in 

mind that we are looking at the logo from the 

backside, it will appear correct when finished.
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Copying to Layers

Now, we need to copy the flipped, extruded logo to frames 13 

through 20. To do this, choose Object > Arrange > Copy to 

Layers with the logo on Frame 12 selected. When the palette 

appears click on Frame 13, then continue to select the 

subsequential frames up to Frame 20 while holding down the Ctrl 

key (Windows) or the Command key (Mac). The selected frames 

will become highlighted as you select them. When you are done 

your palette should look like the example on the right. Now 

press Select to copy. 



 
 

Now go back to Frame 12. You should have a frame with backward facing logo. To make the logo start rotating 

you must first select it, then open the Extrude palette (Effects > Extrude) and change the Y Rotation Angle 

from 0 to -72 and press Apply. Your logo will rotate and appear to be just off its side. 

Next, using these same steps continue to go through the remaining frames and change the Y Rotation Angles 

for the extruded logo through Frame 20. Remember to change the Y Rotation Angle by 18 for each frame. 

Below are examples of the logo and the settings for each progressive frame. 

Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -72, Z = 0

Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -54, Z = 0

Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -36, Z = 0

Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = -18, Z = 0

Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 0, Z = 0

Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 18, Z = 0
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Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 36, Z = 0

Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 54, Z = 0

Light Source:

X = 75, Y = 20, Z = 100

Rotation Angles:

X = 0, Y = 72, Z = 0

  

 
 



 

With the logo rotation out of the way the only thing left for us to do is adjust the frame speed and save our 

project. 

 
Adjusting the Frame Speed

To adjust the frame speed or the speed at 

which frames are going to be played back, 

you must first open the Document Layout 

palette (Layout > Document Layout) and 

hold down the Ctrl key (Windows) or the 

Command key (Mac) while you select all 

the frames. 

Now, open the Document Layout menu 

and select Options. 

 

In the Options dialog box, you only need 

to change is the Frame Speed. The 

Frame Speed icon is represented by a 

stopwatch. Enter 10 as the frame speed 

and press OK. 

Note: A frame speed of 10 refers to 10 

milliseconds. 
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Saving your Animation

The final step is to save the frames you just 

created as an animated gif. To do this, choose 

File > Save. Give your file a name, in this 

example we will name it animated_logo. For 

the file format, select GIF Animated from the 

drop down window. When you are done, press 

Save.



 

 

After pressing Save you will be presented with a Animated GIF Options dialog box. This will allow you to fine 

tune your animated gif. 

●     Transparent Background - Makes the background 

transparent.

●     Auto Crop - Optimizes the size of each frame. 

●     Interlaced - Causes the image to load into a browser a little 

bit at a time giving the viewer the impression that the image is 

loading faster. 

●     Anti-aliasing - Objects will be rendered with an overall 

softened effect.

●     Individual Palette Per Frame - If selected, each GIF frame 

will contain it's own palette. This will create larger file sizes. It 

is recommended only for complex or colorful animations. 

●     Erase Previous Frame - Each frame will be erased and the 

area will be restored to the background before the next frame 

is displayed during playback. 

●     Optimize Frames - Maximizes the size of frames. This option 

is recommended for complex or colorful animations.

●     Differential Frames - Searches for the smallest rectangular 

area possible in the set that contains all of the changes from a 

previous frame in an effort to minimize the file size. 

●     Infinite Loop - Causes the animation to replay itself over and 

over. 

 

For our example we want the animation anti-aliased, we also want to select Differential Frames to cut down on 

the size and we chose Infinite Loop to have our logo animation play repeatedly.

Below are some examples of the completed rotating logo. 

Note: To see Animated gifs in action, you must view them in a graphical Web browser such as Internet 

Explorer or Netscape. 
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