When I import records from 2010 or later, the date is missing from the Year field!

Last Modified: 26th Sep 2014
Category: Bibliography > EndNote
Platform: All
Version: 8 9 X X1 X2
Article Ref.: 13852
»Return to previous search
»Print friendly version of this article.
1 person has found this article useful.

EndNote 13852 This is a known issue with EndNote versions 8, 9, X, X1, and X2. Records import correctly into EndNote X3 and later. There are work-arounds available for all versions mentioned above, but for full compatibility we recommending upgrading to EndNote X3 or later. EndNote X2 Windows Upgrade to version X2.0.4. This is available here: http://endnote.com/support/ENX201_WinMac_updater.asp Note: You may have to update first to X2.0.3, and then again to X2.0.4. Alternatively, you can un-install your existing version of X2 and install the X2.0.4 version from scratch using the following installer: http://download1.isiresearchsoft.com/dsc/ENX204Inst.exe Note: Remember to back up your libraries and documents, and have your Product Key to hand. Mac Upgrade to X2.0.2. This is available here: http://endnote.com/support/ENX201_WinMac_updater.asp Note: You may have to upgrade first to X2.0.1, and then again to X2.0.2 Alternatively, you can un-install your existing version of X2 and install the X2.0.2 version from scratch using the following installer: http://download1.isiresearchsoft.com/dsc/EndNoteX202Installer.dmg Note: Remember to back up your libraries and documents, and have your Product Key to hand. EndNote X1 Windows You must un-install your existing version of X1 and install the X1.0.2 version from scratch using the following installer: http://download1.isiresearchsoft.com/dsc/ENX102Inst.exe Note: Remember to back up your libraries and documents, and have your Product Key to hand. Mac You must un-install your existing version of X1 and install the X1.0.3 version from scratch using the following installer: http://download1.isiresearchsoft.com/dsc/EndNoteX103Installer.dmg Note: Remember to back up your libraries and documents, and have your Product Key to hand. EndNote 8, 9, and X There is a plugin available for EndNote 8, 9, and X, but some manual setting up is required. These instructions may look long, but each step is very simple and straight forward. This procedure modifies the work flow of importing records to use the "Custom 7" field as a temporary placeholder for "Year" information, then it automatically moves the data into the "Year" field, provided the Year field is empty. This workaround requires you to use special connection files and filters so the Year information is imported into Custom 7 field rather than the Year field. Please click here to jump to Windows Instructions or here to jump to Mac OSX instructions. Windows 1. Download the Plugin and content files from: http://kbportal.thomson.com/utility/getfile.aspx?rid=4971 2. Unzip the files to a convenient place, such as a folder on your desktop. 3. Open this folder. Move the files 2010EN89.dll (for EndNote 8 and 9) or 2010ENX.dll (for EndNote X) to the following folder: 32-bit Windows: C:\Program Files\EndNote(Version Number)\Plugins\ 64-bit Windows: C:\Program Files(x86)\EndNote(Version Number)\Plugins\ 4. Open EndNote. Go to the Edit Menu, and choose Preferences. 5. Select Reference Types and click the Modify Reference Types button. 6. Scroll down the list to the Generic Name of Custom 7. 7. Add the text Custom 7 to the blank box to the right of Custom 7. If the box already reads Custom 7 in both places or has a custom name on the right, simply click in the box to the right. We need to get it to look like this: 8. Click the Apply to All Ref Types box. 9. Click OK and close EndNote. 10. In the temporary folder we created in Step 2, open the Connections folder. On your keyboard hold down CTRL and press A to select all of the files in the folder, and then CTRL and C to copy them. 11. Paste them (CTRL and V) into the following folder: 32-bit Windows: C:\Program Files\EndNote(Version Number)\Connections\ 64-bit Windows: C:\Program Files(x86)\EndNote(Version Number)\Connections\ NOTE:The updated connection files and filters will have (2010) in the name, like PubMed (NLM) (2010)- be sure to use these when importing into EndNote and not old older, non-2010 versions. 12. In the temporary folder we created in Step 2, open the Filters folder. On your keyboard hold down CTRL and press A to select all of the files in the folder, and then CTRL and C to copy them. 13. Paste them (CTRL and V) into the following folder: 32-bit Windows: C:\Program Files\EndNote(Version Number)\Filters\ 64-bit Windows: C:\Program Files(x86)\EndNote(Version Number)\Filters\ You have finished applying the plugin. All future imports into EndNote will now contain the correct year when using the 2010 connection files and filters. NOTE: We at Adept Scientific have had reports from some customers that a further step is required to get it working accurately on some machines: If a Connection file isn't working: 1. Start EndNote and go to Edit > Connection Files > Open Connection Manager. 2. Highlight the Connection file(s) in question and press Edit. 3. Make a trivial change to the 'Comments and Limitations' (the 'description' box you see in front of you), such as adding an extra space or a carriage return at the end of the comments. 4. File > Save. Now close the Connection Filter Editor and re-try importing data with the connection file. If a Filter isn't working: 1. Start EndNote and go to Edit > Import Filers > Open Filter Manager. 2. Highlight the Import filters(s) in question and press Edit. 3. Make a trivial change to the 'Comments and Limitations' (the 'description' box you see in front of you), such as adding an extra space or a carriage return at the end of the comments. 4. File > Save. Now close the Connection Filter Editor and re-try importing data with the import filer. Mac OS X 1. Download the Plugin and content filesfrom: http://endnote.com/support/Faqs/Import/2010End.zip 2. Unzip the files to a convenient place, such as folder on your desktop. 3. Open this folder. Move the files 2010EN89.bundle (for EndNote 8 and 9) or 2010ENX.bundle (for EndNote X) to the following folder: Macintosh HD:Applications:EndNote(Version Number):Plugins NOTE: Testing was limited with EndNote 8 and 9 on OSX 10.3.x and 10.4.x. It is not tested or supported with 10.5 or later. 4. Open EndNote. Go to the EndNote Menu, and choose Preferences 5. Select Reference Types and click the Modify Reference Types button. 6. Scroll down the list to the Generic Name of Custom 7. 7. Add the text Custom 7 to the blank box to the right of Custom 7. If the box already reads Custom 7 in both places or has a custom name on the right, simply click in the box to the right. We need to get it to look like this: 8. Click the Apply to All Ref Types box 9. Click OK and close EndNote 10. In the temporary folder we created in Step 2, open the Connections folder. On your keyboard hold down Command key () and press A to select all of the files in the folder, and then Command and C to copy them. 11. Paste them (Command and V) into the folder: Macintosh HD:Applications:EndNote(Version Number):Connections NOTE:The updated connection files and filters will have (2010) in the name, like PubMed (NLM) (2010)- be sure to use these when importing into EndNote and not old older, non-2010 versions. 12. In the temporary folder we created in Step 2, open the Filters folder. On your keyboard hold down Command and press A to select all of the files in the folder, and then Command and C to copy them. 13. Paste (Command and V) into the folder: Macintosh HD:Applications:EndNote(Version Number):Filters You have finished applying the plugin. All future imports into EndNote will now contain the correct year when using the 2010 connection files and filters. NOTE: We at Adept Scientific have had reports from some customers that a further step is required to get it working accurately on some machines: If a Connection file isn't working: 1. Start EndNote and go to Edit > Connection Files > Open Connection Manager. 2. Highlight the Connection file(s) in question and press Edit. 3. Make a trivial change to the 'Comments and Limitations' (the 'description' box you see in front of you), such as adding an extra space or a carriage return at the end of the comments. 4. File > Save. Now close the Connection Filter Editor and re-try importing data with the connection file. If a Filter isn't working: 1. Start EndNote and go to Edit > Import Filers > Open Filter Manager. 2. Highlight the Import filters(s) in question and press Edit. 3. Make a trivial change to the 'Comments and Limitations' (the 'description' box you see in front of you), such as adding an extra space or a carriage return at the end of the comments. 4. File > Save. Now close the Connection Filter Editor and re-try importing data with the import filer. EndNote All 8 en Y Connection File

If you can't find a solution on the Knowledge Base then please contact us on the Technical Support Request Form or by email or by telephone on +44 (0) 203 695 7810

For the time being we are unable to offer the following product ranges although we are currently working hard to increase the number of products we can offer in the future. Please contact us to talk about alternative products that we may be able to offer you.