Getting Started with GenStat - A Simple example.

Last Modified: 3rd Jan 2013
Category: Mathematics and Simulation > GenStat
Version: All
Article Ref.: 104DE
»Return to previous search
»Print friendly version of this article.
1 person has found this article useful.

GenStat 104DE This is a brief introduction to the three main stages in analysing data with the Windows version of GenStat. These are: loading data, performing the required analysis, and saving the results. A more complete introduction to GenStat can be found in the online Guide to GenStat: Introduction (pdf). This can be found by selecting the Introduction item on the GenStat Guides section of the Help menu. Loading Data The easiest way to enter new data into GenStat is by using a spreadsheet. From the menu bar select Spread, New, then Create. This will open a dialog in which you can specify the size and type of the spreadsheet. For the time being, the default settings can be used; press the OK button to continue. A window containing a spreadsheet of the default size (100 rows and 10 columns) will appear, with a * in every cell. This is how GenStat represents a "missing value", that is an unknown quantity. To enter data in the spreadsheet click on the cell in row 1, column C1. This will be highlighted in blue, indicating that it is the current cell. You can now type a value, and press Enter to move on to the next cell (row 2, column C1). Enter the following set of data in columns C1 and C2: After entering the value 12 you will need to click on row 1, column C2 to move to the second column. Once all the data has been entered select the Spread menu again, this time locating the Delete option from which you can select Empty Rows + Columns. This will shrink the spreadsheet to the size of the data that you have entered. The spreadsheet should now appear as shown above. The data you have entered is displayed in the spreadsheet window but cannot be accessed by GenStat until it is saved as GenStat data. By default, this should happen automatically when you switch focus to any other window; you should see a number of messages appearing in the Output window to indicate this has occurred. If you select click on the Data tab on the left hand panel, and then double-click the All Data, you should obtain a listing of the variables C1 and C2 (see below). If, for any reason, this automatic update does not appear to work (for example, it may have been disabled on the Spreadsheet Options) you can make the update manually. From the Spread menu select Update, then Changed Data to GenStat. This will create GenStat data structures containing your data. Messages should now appear in the Output Window showing that your data has been successfully loaded. You can also use the Toolbar to save your data to GenStat, by clicking on the button. Statistical Analysis The Stats item on the menu bar lists various forms of analysis that can be performed on your data. For example, you can fit a straight line to the data that you have just entered. Select Linear Models from the choices listed under Regression Analysis on the Stats menu. This will bring up the Linear Regression menu that allows you to specify your data and various other options controlling the analysis. Click in the box labelled Response Variate and then double-click on C2 in the Available Data list. Likewise, set the Explanatory Variate to C1. Then click on Run. The following image shows the menu with the data entered. The results from the regression of C2 on C1 will appear in the Output window. You can use the scroll bar to move up and down in the window if it is not large enough to display all the output at once. Returning to the Linear Regression menu you can use the Further Output button to produce more output from the analysis. Select Graph of Fitted Model and then press OK. This will open the GenStat Graphics Viewer containing a graph of the data and fitted line. Saving the Results The results of the regression analysis are contained in the Output Window. You can save this to a file by selecting Save As from the File menu and then specifying an appropriate name for the saved output. Note that the File menu always operates on the currently active window, which is indicated by highlighting the title bar. Click on the title bar of the Output Window to ensure it is the active window before using the File menu. Product Information GenStat All en All

If you can't find a solution on the Knowledge Base then please contact us on the Technical Support Request Form or by email or by telephone on +44 (0) 203 695 7810

For the time being we are unable to offer the following product ranges although we are currently working hard to increase the number of products we can offer in the future. Please contact us to talk about alternative products that we may be able to offer you.